Пакетная загрузка сведений по помещениям и оборудованию из MS Excel

Для пакетной загрузки сведений по помещениям и оборудованию необходимо воспользоваться прилагаемым шаблоном и плагином платформы Lement Pro (на базе которой реализовано решение SODIS Building FM) для Excel.

Последовательность действий, для экспорта объектов на площадку Lement Pro.

  • Плагин расположен на вкладке ленты Lement Pro.

11-1

  • После запуска плагина запускается окно, которое позволяет авторизоваться на площадке Lement Pro.

22

  • Во вкладке «BIM», при помощи команды «Attach Lement Pro Bim model», можно подключиться к требуемой BIM модели. В дальнейшем, при повторном открытии файла Excel, повторное подключение к BIM модели не требуется.

33

  • В случае успешного подключения BIM модели ее имя будет отображено в окне плагина.

44

  • Во вкладке «Project», при помощи команды «Attach Lement Pro project», можно подключиться у требуемому проекту. В дальнейшем, при повторном открытии файла Excel, повторное подключение к проекту не требуется.

55

  • В случае успешного подключения проекту, его имя будет отображено в окне плагина.

66

  • Следующим этапом можно переходить к созданию объектов на площадке Lement Pro по указанным в Excel файле данным. Необходимо перейти на вкладку «Table» и запустить команду «Export to Lement Pro». После этого запускается экспорт.

77

  • Перед стартом экспорта на площадку необходимо выбрать режим экспорта.

88

  • В случает ответа «Да», объекты уже экспортированные на площадку будут проверяться на изменения значений в таблице, и в случае наличия изменения значений или добавления новых значений, будет произведено их редактирование. Также, если значения объектов были уже произведены на площадке, то произойдет редактирование в соответствии со значением указанным в таблице (в качестве нового значения, будет принято значение из таблицы).
  • В случает ответа «Нет», объекты уже экспортированные на площадку игнорируются и с ними не предпринимается никаких действий.
  1. После успешного экспорта объекта ячейка с идентификатором заполняется.

99

  1. При экспорте большого количества объектов процесс состояния экспорта отображается в информационной строке Excel, а также в нижнем левом углу плагина.

10

10-1

  1. Процесс экспорта объектов может быть прерван на кнопку «Cancel» в правом нижнем углу окна плагина.

  2. Следующим этапом можно переходить к привязке экспортированных объектов к элементам BIM модели. Для этого необходимо перейти на вкладку «Table» и запустить команду«UpdateBIM elements links». После этого запускается процесс привязки.

  3. Информирование о прогрессе в процессе привязки осуществляется аналогичным образом.

Общие правила подготовки файла для экспорта.

  • Первая строка документа содержит текстовые заголовки, служит для информационных целей.
  • Во второй строке содержится список идентификаторов атрибутов Lement Pro.
  • Строка с идентификаторами обязательно должна содержать «id».

13

  1. Также для каждого экспортируемого тип должны быть указаны обязательные к заполнению идентификаторы. Kак правило, обязательно указать «

typeName

», «

name

».

  1. Тип элемента (колонка «

») указывается с разделителем в виде «

/

», например:

Здание/Элемент здания/Оборудование/Оборудование.Экземпляр

15

  1. Вначале рекомендуется выводить все обязательные идентификаторы.

  2. Аналогичным образом указаны не обязательные для создания объекта идентификаторы (на представленном изображении закрашены серым цветом).

16

  1. В последующих строках содержатся данные для экспорта элементов на площадку Lement Pro.

  2. Для задания привязки экспортируемых элементов к элементам BIM модели, необходимо использовать идентификаторы со следующими именами:

  • linkedBimElementsRevitUniqueId, уникальный идентификатор элемента модели в Autodesk Revit
  • linkedBimElementsRevitExportId, униальный идентификатор элемента модели Autodesk Navisworks, созданной на основе моделей в формате rvt.

17

Правила выбора объектов для экспорта.

  • По умолчанию, при запуске экспорта, в очередь создания объектов попадают все объекты для которых возможен экспорт.

  • Есть возможность выбора отдельных объектов для экспорта. Для этого необходимо на активном листе выбрать строки с объектами, экспорт которых необходим (выбранной считается строка выделенная целиком, через левую панель индексов строк или строка, в которой выбрано 2 и более ячеек).

  • При этом в очередь создания попадают выбранные объекты и все родительские объекты расположенные выше по иерархии, по отношению к выбранным объектам.

  • Если объект данной очереди не создан, то произойдет его экспорт на площадку Lement Pro (относится и к объектам являющимися родительскими по отношению к выбранным);

  • Если объект создан и пользователь производит экспорт в режиме без редактирования существующих объектов, то с объектом не будет предпринято никаких действий:

  • Если объект создан и пользователь производит экспорт в режиме с редактированием существующих объектов, то редактированию будут подвергнуты только выбранные объекты (родительские объекты будут проигнорированы).

Организация ссылок между объектами при помощи ссылок в заголовках.

  • Для создания структуры объектов, файл Excel для экспорта, должен содержать ссылки в заголовках листов, которые указывают на заголовок столбца листа, на котором происходит поиск требуемого родительского элемента. Ссылки в заголовках должны начинаться «link»

  • Общая схема создания ссылок между объектами:

  • Задаётся ссылка между объектами через заголовок.

18

  • В дальнейшем, при экспорте объектов, происходит поиск объекта на листе, на который указывает ссылка с таблицы зависимых объектов (поиск происходит уникальному значению параметра). Ссылки между объектами таблицы можно представить в виде:

20

Например, «link_name», в данном случае ссылка из объекта «Помещение/Помещение», указывает на объект здание ссылаясь на ячейку в заголовке на листе с объектами типа «Здание/Уровень».

21

  1. Ссылка формируется при помощи функции «

СЦЕПИТЬ

», в которой при помощи первого аргумента необходимо использовать префикс «

link_

», а вторым аргументом выступает ссылка на ячейку из заголовка на другой странице, в данном случае «

Здания!C2

»

=СЦЕПИТЬ(“link_“;Здания!C2)

  1. Ссылок в заголовке объекта может быть неограниченное количество.

23

Организация ссылок между объектами при помощи создания листов ссылок

  • Для создания структуры объектов файл Excel для экспорта должен содержать листы ссылок. Листы такого типа должны начинаться с префикса «lplinks», например «lplinks_Links». Количество листов со ссылками не ограничего.

  • Структура листа ссылок должна быть организована следующим образом:

  • Первый ряд носит информационный характер, в данном случае, это просто тестовые метки «ID1», «ID2».

  • Во втором ряду могут быть указаны имена идентификаторов, по которым происходит поиск и сопоставление объектов на остальных листах. Но может быть не указано ничего.

  • Далее указаны идентификаторы объектов.

24

  1. В столбце 1 указывается идентификатор главного объекта, в столбце 2 указывается идентификатор зависимого объекта. В данном примере в роли главного объекта выступает объекта типа «Помещение», а зависимого «Оборудование.Экземпляр».

25

  1. Или как в примере ниже в роли главного объекта выступает объекта типа «

Оборудование.Тип

», а зависимого «

Оборудование.Экземпляр

26

  1. Если объект ни от кого не зависит и ни на кого не ссылается, его идентификатор должен быть указан в столбце 1, при этом в соответствующей ячейке столбца 2 ничего не указывается.

27

Организация ссылок между объектами при помощи нумерованных заголовков

  • В случае создания иерархии объектов при помощи нумерованных заголовков, таблица должна содержать столбец с идентификатором «LementProBS». Если данный столбец присутствует, то иерархия объектов выстраивается в соответствии с уровнями вложенности объектов, указанных в нем.

28

  • В качестве разделителя уровней выступает знак «.».
  • Указатели уровней не обязательно должны располагать по порядку. Например сначала могут быть перечислены уровни вложенности «1, 2,3…n», затем «1.1, 1.2, 1.3…1.n» и так далее.